Ameritron’s QSK-5-PC mod for AL80B

Disclaimer: I don’t assume any responsibility for results of performing the following steps. These are simply my impressions of the mod and how I performed it.

Contents of mod kit. Click for larger

I spent about 2-1/2 hours today installing Ameritron’s internal QSK board into my new AL80B amplifier. About 25% of that time was spent¬†translating what the instructions said into what they meant to say.

The Final Result is that I now have a whisper-quiet kilowatt with silky smooth QSK. There’s absolutely no difference in the ambient sound level here in the shack between using the K3 barefoot or with that orange 3-500Z online. As with the K3 barefoot, I can hear the receiver between Morse characters.

No more clacking relays – only the wattmeter gives any indication of QRO.

I’m happy, it works as expected and as advertised. But the process of getting there could use some improvement. Instructions were vague in parts and misleading in others.

For the benefit of others who may be doing the same mod to their AL80B, here are a few attempts at clarification. I may be nitpicking, but whether I’m building a QRP transceiver or modifying an amp, I like to be 100% sure of what the instructions are asking me to do with no ambiguity.

.

What Step 7 should say is, “If there is a short jumper wire connecting the “12 Volts” jack to the main circuit board, cut it off. As written, I wondered if there was some other “indication” I was supposed to look for.

.

There are two relays and neither of them has a white wire attached. What it should say is, “Remove the white wire at pad “PAI” near the smaller of the two T/R relays. Remove the end attached to the input board as well”.

Click for larger image

.

Steps 10 and 11 have you install two pieces (one end each) of RG178. Notice that Step 11 instructs you to connect both the center conductor and the shield whereas Step 10 doesn’t mention the shield. Is this intentional or an oversight? I know that in some past projects I’ve built, one end of the shield of an internal coaxial connection is left unattached to prevent ground loops. However, I took my cue here from the fact that other coaxial connections within the AL80B have their shield connected at both ends and that the Step 10 cable eventually has both ends of the shield connected…so I did the same here, utilizing a nearby ground on the circuit board.

.

One of the final steps has you connecting the final end of a previously installed blue wire to a post on the QSK board:

So here’s what I did per the instructions:

Click for larger

Notice the diode? The only further steps were to neaten the wiring, re-install the tube and button everything back up. I called Ameritron and was told that I was supposed to solder the blue wire to the diode, not directly to the post. The guy told me “Yeah, we need to update that in the manual”.

Yeah, ya think!?

Here’s how it’s supposed to be:

Click for larger

.

As I said, the amp now performs exactly as I’d hoped it would. With the fact that the ’80B’s fan is internal (as opposed to cabinet-mounted), I now have a near silent kilowatt and, as W4TI mentions in his review, I can operate without headphones if I want as there is almost no ambient noise, going to/from transmitting/receiving. A CW op’s dream.

.

.